What’s Vulnerable › Vulnerabilities
CVE-2022-25857: Denial of Service (DoS)
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-30 · updated 2026-06-17
- Weakness: CWE-776
Description
The package org.yaml:snakeyaml from 0 and before 1.31 are vulnerable to Denial of Service (DoS) due missing to nested depth limitation for collections.
Affected products
- Debian Linux: 10.0
- SnakeYAML: before 1.31 — fixed in 1.31
- Maven Org.Yaml:Snakeyaml: before 1.31; 1.10, 1.11, 1.12, 1.13, 1.14, 1.15 (+21) — fixed in 1.31
How to fix
Upgrade to a fixed version: SnakeYAML 1.31; Maven Org.Yaml:Snakeyaml 1.31. Check the vendor advisory for mitigations.
References
- https://bitbucket.org/snakeyaml/snakeyaml/commits/fc300780da21f4bb92c148bc90257201220cf174
- https://bitbucket.org/snakeyaml/snakeyaml/issues/525
- https://github.com/snakeyaml/snakeyaml/commit/fc300780da21f4bb92c148bc90257201220cf174
- https://lists.debian.org/debian-lts-announce/2022/10/msg00001.html
- https://security.netapp.com/advisory/ntap-20240315-0010/
- https://security.snyk.io/vuln/SNYK-JAVA-ORGYAML-2806360
- https://bitbucket.org/snakeyaml/snakeyaml/commits/fc300780da21f4bb92c148bc90257201220cf174
- https://bitbucket.org/snakeyaml/snakeyaml/issues/525
- https://github.com/snakeyaml/snakeyaml/commit/fc300780da21f4bb92c148bc90257201220cf174
- https://lists.debian.org/debian-lts-announce/2022/10/msg00001.html
- https://security.netapp.com/advisory/ntap-20240315-0010/
- https://security.snyk.io/vuln/SNYK-JAVA-ORGYAML-2806360
Get alerted when CVE-2022-25857 or the next vulnerability affects your stack