What’s Vulnerable › Vulnerabilities

CVE-2022-25858: Regular Expression Denial of Service (ReDoS)

Description

The package terser before 4.8.1, from 5.0.0 and before 5.14.2 are vulnerable to Regular Expression Denial of Service (ReDoS) due to insecure usage of regular expressions.

Affected products

How to fix

Upgrade to a fixed version: terser 4.8.1, 5.14.2; Npm Terser 4.8.1, 5.14.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-25858 or the next vulnerability affects your stack