What’s Vulnerable › Vulnerabilities

CVE-2022-25863: Deserialization of Untrusted Data

Description

The package gatsby-plugin-mdx before 2.14.1, from 3.0.0 and before 3.15.2 are vulnerable to Deserialization of Untrusted Data when passing input through to the gray-matter package, due to its default configurations that are missing input sanitization. Exploiting this vulnerability is possible when passing input in both webpack (MDX files in src/pages or MDX file imported as a component in frontend / React code) and data mode (querying MDX nodes via GraphQL). Workaround: If an older version of gatsby-plugin-mdx must be used, input passed into the plugin should be sanitized ahead of processing.

Affected products

How to fix

Upgrade to a fixed version: gatsby-plugin-mdx 2.14.1, 3.15.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-25863 or the next vulnerability affects your stack