What’s Vulnerable › Vulnerabilities
CVE-2022-25865: Command Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-13 · updated 2026-06-17
- Weakness: CWE-88
Description
The package workspace-tools before 0.18.4 are vulnerable to Command Injection via git argument injection. When calling the fetchRemoteBranch(remote: string, remoteBranch: string, cwd: string) function, both the remote and remoteBranch parameters are passed to the git fetch subcommand in a way that additional flags can be set. The additional flags can be used to perform a command injection.
Affected products
- workspace-tools: before 0.18.4 — fixed in 0.18.4
- workspace-tools: before 0.18.4 — fixed in 0.18.4
How to fix
Upgrade to a fixed version: workspace-tools 0.18.4; workspace-tools 0.18.4. Check the vendor advisory for mitigations.
References
- https://github.com/microsoft/workspace-tools/commit/9bc7e65ce497f87e1f363fd47b8f802f3d3cd978
- https://github.com/microsoft/workspace-tools/pull/103
- https://snyk.io/vuln/SNYK-JS-WORKSPACETOOLS-2421201
- https://github.com/microsoft/workspace-tools/commit/9bc7e65ce497f87e1f363fd47b8f802f3d3cd978
- https://github.com/microsoft/workspace-tools/pull/103
- https://snyk.io/vuln/SNYK-JS-WORKSPACETOOLS-2421201
Get alerted when CVE-2022-25865 or the next vulnerability affects your stack