What’s Vulnerable › Vulnerabilities
CVE-2022-25866: Command Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-25 · updated 2026-06-17
- Weakness: CWE-88
Description
The package czproject/git-php before 4.0.3 are vulnerable to Command Injection via git argument injection. When calling the isRemoteUrlReadable($url, array $refs = NULL) function, both the url and refs parameters are passed to the git ls-remote subcommand in a way that additional flags can be set. The additional flags can be used to perform a command injection.
Affected products
- czproject/git-php: before 4.0.3 — fixed in 4.0.3
How to fix
Upgrade to a fixed version: czproject/git-php 4.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/czproject/git-php/commit/5e82d5479da5f16d37a915de4ec55e1ac78de733
- https://github.com/czproject/git-php/releases/tag/v4.0.3
- https://snyk.io/vuln/SNYK-PHP-CZPROJECTGITPHP-2421349
- https://github.com/czproject/git-php/commit/5e82d5479da5f16d37a915de4ec55e1ac78de733
- https://github.com/czproject/git-php/releases/tag/v4.0.3
- https://snyk.io/vuln/SNYK-PHP-CZPROJECTGITPHP-2421349
Get alerted when CVE-2022-25866 or the next vulnerability affects your stack