What’s Vulnerable › Vulnerabilities
CVE-2022-25873: Cross-site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The package vuetify from 2.0.0-beta.4 and before 2.6.10 are vulnerable to Cross-site Scripting (XSS) due to improper input sanitization in the 'eventName' function within the VCalendar component.
Affected products
- Vuetify: from 2.0.1 before 2.6.10; 2.0.0-beta4, 2.0.0-beta5, 2.0.0-beta6, 2.0.0-beta7, 2.0.0-beta8, 2.0.0-beta9 — fixed in 2.6.10
How to fix
Upgrade to a fixed version: Vuetify 2.6.10. Check the vendor advisory for mitigations.
References
- https://codepen.io/5v3n-08/pen/MWGKEjY
- https://github.com/vuetifyjs/vuetify/commit/ade1434927f55a0eccf3d54f900f24c5fa85a176
- https://github.com/vuetifyjs/vuetify/issues/15757
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSBOWERGITHUBVUETIFYJS-3024407
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-3024406
- https://security.snyk.io/vuln/SNYK-JS-VUETIFY-3019858
- https://codepen.io/5v3n-08/pen/MWGKEjY
- https://github.com/vuetifyjs/vuetify/commit/ade1434927f55a0eccf3d54f900f24c5fa85a176
- https://github.com/vuetifyjs/vuetify/issues/15757
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSBOWERGITHUBVUETIFYJS-3024407
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-3024406
- https://security.snyk.io/vuln/SNYK-JS-VUETIFY-3019858
Get alerted when CVE-2022-25873 or the next vulnerability affects your stack