What’s Vulnerable › Vulnerabilities
CVE-2022-2588
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-08 · updated 2026-10-14
- Weakness: CWE-416
Description
It was discovered that the cls_route filter implementation in the Linux kernel would not remove an old filter from the hashtable before freeing it if its handle had the value 0.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 20.04, 22.04
- Linux kernel: before 4.9.326; from 4.10 before 4.14.291; from 4.15 before 4.19.256; from 4.20 before 5.4.211; from 5.5 before 5.10.137; from 5.11 before 5.15.61 — fixed in 4.14.291, 4.19.256, 4.9.326, 5.10.137, 5.15.61, 5.18.18
How to fix
Upgrade to a fixed version: Linux kernel 4.14.291, 4.19.256, 4.9.326, 5.10.137. Check the vendor advisory for mitigations.
References
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-2588
- https://github.com/Markakd/CVE-2022-2588
- https://lore.kernel.org/netdev/20220809170518.164662-1-cascardo@canonical.com/T/#u
- https://ubuntu.com/security/notices/USN-5557-1
- https://ubuntu.com/security/notices/USN-5560-1
- https://ubuntu.com/security/notices/USN-5560-2
- https://ubuntu.com/security/notices/USN-5562-1
- https://ubuntu.com/security/notices/USN-5564-1
- https://ubuntu.com/security/notices/USN-5565-1
- https://ubuntu.com/security/notices/USN-5566-1
- https://ubuntu.com/security/notices/USN-5567-1
- https://ubuntu.com/security/notices/USN-5582-1
Get alerted when CVE-2022-2588 or the next vulnerability affects your stack