What’s Vulnerable › Vulnerabilities
CVE-2022-25881
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-31 · updated 2026-06-17
- Weakness: CWE-1333
Description
This affects versions of the package http-cache-semantics before 4.1.1. The issue can be exploited via malicious request header values sent to a server, when that server reads the cache policy from the request using this library.
Affected products
- Http-Cache-Semantics Project Http-Cache-Semantics: before 4.1.1 — fixed in 4.1.1
How to fix
Upgrade to a fixed version: Http-Cache-Semantics Project Http-Cache-Semantics 4.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/kornelski/http-cache-semantics/blob/master/index.js%23L83
- https://security.netapp.com/advisory/ntap-20230622-0008/
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-3253332
- https://security.snyk.io/vuln/SNYK-JS-HTTPCACHESEMANTICS-3248783
- https://github.com/kornelski/http-cache-semantics/blob/master/index.js%23L83
- https://security.netapp.com/advisory/ntap-20230622-0008/
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-3253332
- https://security.snyk.io/vuln/SNYK-JS-HTTPCACHESEMANTICS-3248783
Get alerted when CVE-2022-25881 or the next vulnerability affects your stack