What’s Vulnerable › Vulnerabilities

CVE-2022-25883: semver vulnerable to Regular Expression Denial of Service

Description

Versions of the package semver before 7.5.2 are vulnerable to Regular Expression Denial of Service (ReDoS) via the function new Range, when untrusted user data is provided as a range.

Affected products

How to fix

Upgrade to a fixed version: semver 5.7.2, 6.3.1, 7.5.3; Npm Semver 7.5.2, 6.3.1, 5.7.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-25883 or the next vulnerability affects your stack