What’s Vulnerable › Vulnerabilities
CVE-2022-25885: Denial of Service (DoS)
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-01 · updated 2026-06-17
- Weakness: CWE-20
Description
The package muhammara before 2.6.0; all versions of package hummus are vulnerable to Denial of Service (DoS) when PDFStreamForResponse() is used with invalid data.
Affected products
- Muhammara Project Muhammara: before 2.6.0 — fixed in 2.6.0
How to fix
Upgrade to a fixed version: Muhammara Project Muhammara 2.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/galkahana/HummusJS/issues/439
- https://github.com/julianhille/MuhammaraJS/commit/0a6427eec82ef2978995e453de2dc0d6224dd46c
- https://github.com/julianhille/MuhammaraJS/issues/188
- https://security.snyk.io/vuln/SNYK-JS-HUMMUS-3091139
- https://security.snyk.io/vuln/SNYK-JS-MUHAMMARA-3091137
- https://github.com/galkahana/HummusJS/issues/439
- https://github.com/julianhille/MuhammaraJS/commit/0a6427eec82ef2978995e453de2dc0d6224dd46c
- https://github.com/julianhille/MuhammaraJS/issues/188
- https://security.snyk.io/vuln/SNYK-JS-HUMMUS-3091139
- https://security.snyk.io/vuln/SNYK-JS-MUHAMMARA-3091137
Get alerted when CVE-2022-25885 or the next vulnerability affects your stack