What’s Vulnerable › Vulnerabilities
CVE-2022-25887: Regular Expression Denial of Service (ReDoS)
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-30 · updated 2026-06-17
- Weakness: CWE-1333
Description
The package sanitize-html before 2.7.1 are vulnerable to Regular Expression Denial of Service (ReDoS) due to insecure global regular expression replacement logic of HTML comment removal.
Affected products
- apostrophecms sanitize-html: before 2.7.1 — fixed in 2.7.1
How to fix
Upgrade to a fixed version: apostrophecms sanitize-html 2.7.1. Check the vendor advisory for mitigations.
References
- https://github.com/apostrophecms/sanitize-html/commit/b4682c12fd30e12e82fa2d9b766de91d7d2cd23c
- https://github.com/apostrophecms/sanitize-html/pull/557
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-3008102
- https://security.snyk.io/vuln/SNYK-JS-SANITIZEHTML-2957526
- https://github.com/apostrophecms/sanitize-html/commit/b4682c12fd30e12e82fa2d9b766de91d7d2cd23c
- https://github.com/apostrophecms/sanitize-html/pull/557
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-3008102
- https://security.snyk.io/vuln/SNYK-JS-SANITIZEHTML-2957526
Get alerted when CVE-2022-25887 or the next vulnerability affects your stack