What’s Vulnerable › Vulnerabilities
CVE-2022-25891: Denial of Service (DoS)
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-15 · updated 2026-06-17
Description
The package github.com/containrrr/shoutrrr/pkg/util before 0.6.0 are vulnerable to Denial of Service (DoS) via the util.PartitionMessage function. Exploiting this vulnerability is possible by sending exactly 2000, 4000, or 6000 characters messages.
Affected products
- github.com/containrrr/shoutrrr/pkg/util: before 0.6.0 — fixed in 0.6.0
How to fix
Upgrade to a fixed version: github.com/containrrr/shoutrrr/pkg/util 0.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/containrrr/shoutrrr/commit/6a27056f9d7522a8b493216195cb7634bf4b5c42
- https://github.com/containrrr/shoutrrr/issues/240
- https://github.com/containrrr/shoutrrr/pull/242
- https://github.com/containrrr/shoutrrr/releases/tag/v0.6.0
- https://snyk.io/vuln/SNYK-GOLANG-GITHUBCOMCONTAINRRRSHOUTRRRPKGUTIL-2849059
- https://github.com/containrrr/shoutrrr/commit/6a27056f9d7522a8b493216195cb7634bf4b5c42
- https://github.com/containrrr/shoutrrr/issues/240
- https://github.com/containrrr/shoutrrr/pull/242
- https://github.com/containrrr/shoutrrr/releases/tag/v0.6.0
- https://snyk.io/vuln/SNYK-GOLANG-GITHUBCOMCONTAINRRRSHOUTRRRPKGUTIL-2849059
Get alerted when CVE-2022-25891 or the next vulnerability affects your stack