What’s Vulnerable › Vulnerabilities
CVE-2022-25892: Denial of Service (DoS)
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-01 · updated 2026-06-17
Description
The package muhammara before 2.6.1, from 3.0.0 and before 3.1.1; all versions of package hummus are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be parsed.
Affected products
- Muhammara Project Muhammara: before 2.6.1; 3.0.0, 3.1.0 — fixed in 2.6.1
How to fix
Upgrade to a fixed version: Muhammara Project Muhammara 2.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/galkahana/HummusJS/issues/463
- https://github.com/julianhille/MuhammaraJS/commit/1890fb555eaf171db79b73fdc3ea543bbd63c002
- https://github.com/julianhille/MuhammaraJS/commit/90b278d09f16062d93a4160ef0a54d449d739c51
- https://github.com/julianhille/MuhammaraJS/issues/214
- https://security.snyk.io/vuln/SNYK-JS-HUMMUS-3091138
- https://security.snyk.io/vuln/SNYK-JS-MUHAMMARA-3060320
- https://github.com/galkahana/HummusJS/issues/463
- https://github.com/julianhille/MuhammaraJS/commit/1890fb555eaf171db79b73fdc3ea543bbd63c002
- https://github.com/julianhille/MuhammaraJS/commit/90b278d09f16062d93a4160ef0a54d449d739c51
- https://github.com/julianhille/MuhammaraJS/issues/214
- https://security.snyk.io/vuln/SNYK-JS-HUMMUS-3091138
- https://security.snyk.io/vuln/SNYK-JS-MUHAMMARA-3060320
Get alerted when CVE-2022-25892 or the next vulnerability affects your stack