What’s Vulnerable › Vulnerabilities
CVE-2022-25893: Arbitrary Code Execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-21 · updated 2026-06-17
- Weakness: CWE-471
Description
The package vm2 before 3.9.10 are vulnerable to Arbitrary Code Execution due to the usage of prototype lookup for the WeakMap.prototype.set method. Exploiting this vulnerability leads to access to a host object and a sandbox compromise.
Affected products
- patriksimek vm2: before 3.9.10 — fixed in 3.9.10
How to fix
Upgrade to a fixed version: patriksimek vm2 3.9.10. Check the vendor advisory for mitigations.
References
- https://github.com/patriksimek/vm2/issues/444
- https://github.com/patriksimek/vm2/pull/445
- https://github.com/patriksimek/vm2/pull/445/commits/3a9876482be487b78a90ac459675da7f83f46d69
- https://security.snyk.io/vuln/SNYK-JS-VM2-2990237
- https://github.com/patriksimek/vm2/issues/444
- https://github.com/patriksimek/vm2/pull/445
- https://github.com/patriksimek/vm2/pull/445/commits/3a9876482be487b78a90ac459675da7f83f46d69
- https://security.snyk.io/vuln/SNYK-JS-VM2-2990237
Get alerted when CVE-2022-25893 or the next vulnerability affects your stack