What’s Vulnerable › Vulnerabilities
CVE-2022-25914: Remote Code Execution (RCE)
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-08 · updated 2026-06-17
Description
The package com.google.cloud.tools:jib-core before 0.22.0 are vulnerable to Remote Code Execution (RCE) via the isDockerInstalled function, due to attempting to execute input.
Affected products
- com.google.cloud.tools:jib-core: before 0.22.0 — fixed in 0.22.0
How to fix
Upgrade to a fixed version: com.google.cloud.tools:jib-core 0.22.0. Check the vendor advisory for mitigations.
References
- https://github.com/GoogleContainerTools/jib/commit/67fa40bc2c484da0546333914ea07a89fe44eaaf
- https://github.com/GoogleContainerTools/jib/pull/3744
- https://security.snyk.io/vuln/SNYK-JAVA-COMGOOGLECLOUDTOOLS-2968871
- https://github.com/GoogleContainerTools/jib/commit/67fa40bc2c484da0546333914ea07a89fe44eaaf
- https://github.com/GoogleContainerTools/jib/pull/3744
- https://security.snyk.io/vuln/SNYK-JAVA-COMGOOGLECLOUDTOOLS-2968871
Get alerted when CVE-2022-25914 or the next vulnerability affects your stack