What’s Vulnerable › Vulnerabilities
CVE-2022-25916
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-01 · updated 2026-06-17
- Weakness: CWE-78
Description
Versions of the package mt7688-wiscan before 0.8.3 are vulnerable to Command Injection due to improper input sanitization in the 'wiscan.scan' function.
Affected products
- mt7688-wiscan: before 0.8.3 — fixed in 0.8.3
How to fix
Upgrade to a fixed version: mt7688-wiscan 0.8.3. Check the vendor advisory for mitigations.
References
- https://github.com/simenkid/mt7688-wiscan/blob/master/index.js%23L22
- https://github.com/simenkid/mt7688-wiscan/commit/ff6d6567c65b4e972916a8fbc4533212f20a2fa5
- https://security.snyk.io/vuln/SNYK-JS-MT7688WISCAN-3177394
- https://github.com/simenkid/mt7688-wiscan/blob/master/index.js%23L22
- https://github.com/simenkid/mt7688-wiscan/commit/ff6d6567c65b4e972916a8fbc4533212f20a2fa5
- https://security.snyk.io/vuln/SNYK-JS-MT7688WISCAN-3177394
Get alerted when CVE-2022-25916 or the next vulnerability affects your stack