What’s Vulnerable › Vulnerabilities

CVE-2022-2592

Description

A lack of length validation in Snippet descriptions in GitLab CE/EE affecting all versions prior to 15.1.6, 15.2 prior to 15.2.4 and 15.3 prior to 15.3.2 allows an authenticated attacker to create a maliciously large Snippet which when requested with or without authentication places excessive load on the server, potential leading to Denial of Service.

Affected products

How to fix

Upgrade to a fixed version: GitLab 15.1.6, 15.2.4, 15.3.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-2592 or the next vulnerability affects your stack