What’s Vulnerable › Vulnerabilities
CVE-2022-25923
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-06 · updated 2026-06-17
- Weakness: CWE-78
Description
Versions of the package exec-local-bin before 1.2.0 are vulnerable to Command Injection via the theProcess() functionality due to improper user-input sanitization.
Affected products
- exec-local-bin: before 1.2.0 — fixed in 1.2.0
How to fix
Upgrade to a fixed version: exec-local-bin 1.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/saeedseyfi/exec-local-bin/blob/92db00bde9d6e2d83410849f898df12f075b73b0/index.js%23L9
- https://github.com/saeedseyfi/exec-local-bin/commit/d425866375c85038133a6f79db2aac66c0a72624
- https://security.snyk.io/vuln/SNYK-JS-EXECLOCALBIN-3157956
- https://github.com/saeedseyfi/exec-local-bin/blob/92db00bde9d6e2d83410849f898df12f075b73b0/index.js%23L9
- https://github.com/saeedseyfi/exec-local-bin/commit/d425866375c85038133a6f79db2aac66c0a72624
- https://security.snyk.io/vuln/SNYK-JS-EXECLOCALBIN-3157956
Get alerted when CVE-2022-25923 or the next vulnerability affects your stack