What’s Vulnerable › Vulnerabilities

CVE-2022-25927

Description

Versions of the package ua-parser-js from 0.7.30 and before 0.7.33, from 0.8.1 and before 1.0.33 are vulnerable to Regular Expression Denial of Service (ReDoS) via the trim() function.

Affected products

How to fix

Upgrade to a fixed version: ua-parser-js 0.7.33, 1.0.33. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-25927 or the next vulnerability affects your stack