What’s Vulnerable › Vulnerabilities
CVE-2022-25936
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-30 · updated 2026-06-17
- Weakness: CWE-22
Description
Versions of the package servst before 2.0.3 are vulnerable to Directory Traversal due to improper sanitization of the filePath variable.
Affected products
- servst: before 2.0.3 — fixed in 2.0.3
How to fix
Upgrade to a fixed version: servst 2.0.3. Check the vendor advisory for mitigations.
References
- https://gist.github.com/lirantal/691d02d607753d54856f9335f9a1692f
- https://github.com/andrepolischuk/servst/commit/f7cae5d2d7c64c86bc512e1e50614240396ef114
- https://security.snyk.io/vuln/SNYK-JS-SERVST-3244896
- https://gist.github.com/lirantal/691d02d607753d54856f9335f9a1692f
- https://github.com/andrepolischuk/servst/commit/f7cae5d2d7c64c86bc512e1e50614240396ef114
- https://security.snyk.io/vuln/SNYK-JS-SERVST-3244896
Get alerted when CVE-2022-25936 or the next vulnerability affects your stack