What’s Vulnerable › Vulnerabilities
CVE-2022-25937
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-13 · updated 2026-06-17
- Weakness: CWE-22
Description
Versions of the package glance before 3.0.9 are vulnerable to Directory Traversal that allows users to read files outside the public root directory. This is related to but distinct from the vulnerability reported in [CVE-2018-3715](https://security.snyk.io/vuln/npm:glance:20180129).
Affected products
- glance: before 3.0.9 — fixed in 3.0.9
How to fix
Upgrade to a fixed version: glance 3.0.9. Check the vendor advisory for mitigations.
References
- https://github.com/jarofghosts/glance/commit/8cecfe90286e0c45a5494067f1b592d0ccfeabac
- https://security.snyk.io/vuln/SNYK-JS-GLANCE-3318395
- https://github.com/jarofghosts/glance/commit/8cecfe90286e0c45a5494067f1b592d0ccfeabac
- https://security.snyk.io/vuln/SNYK-JS-GLANCE-3318395
Get alerted when CVE-2022-25937 or the next vulnerability affects your stack