What’s Vulnerable › Vulnerabilities
CVE-2022-2597: Visual Portfolio < 2.19.0 - Contributor+ CSS Injection
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-05 · updated 2026-06-17
- Weakness: CWE-863
Description
The Visual Portfolio, Photo Gallery & Post Grid WordPress plugin before 2.19.0 does not have proper authorisation checks in some of its REST endpoints, allowing users with a role as low as contributor to call them and inject arbitrary CSS in arbitrary saved layouts
Affected products
- Visual Portfolio, Photo Gallery & Post Grid: before 2.19.0 — fixed in 2.19.0
How to fix
Upgrade to a fixed version: Visual Portfolio, Photo Gallery & Post Grid 2.19.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/3ffcee7c-1e03-448c-8006-a9405658cdb7
- https://wpscan.com/vulnerability/3ffcee7c-1e03-448c-8006-a9405658cdb7
Get alerted when CVE-2022-2597 or the next vulnerability affects your stack