What’s Vulnerable › Vulnerabilities
CVE-2022-2598: Out-of-bounds Write to API in vim/vim
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-01 · updated 2026-06-17
- Weakness: CWE-787
Description
Out-of-bounds Write to API in GitHub repository vim/vim prior to 9.0.0100.
Affected products
- Debian Linux: 10.0
- vim/vim: before 9.0.0100 — fixed in 9.0.0100
How to fix
Upgrade to a fixed version: vim/vim 9.0.0100. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/4e677b9c40ccbc5f090971b31dc2fe07bf05541d
- https://huntr.dev/bounties/2f08363a-47a2-422d-a7de-ce96a89ad08e
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://github.com/vim/vim/commit/4e677b9c40ccbc5f090971b31dc2fe07bf05541d
- https://huntr.dev/bounties/2f08363a-47a2-422d-a7de-ce96a89ad08e
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
Get alerted when CVE-2022-2598 or the next vulnerability affects your stack