What’s Vulnerable › Vulnerabilities
CVE-2022-2599: Anti-Malware Security and Brute-Force Firewall < 4.21.83 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The Anti-Malware Security and Brute-Force Firewall WordPress plugin before 4.21.83 does not sanitise and escape some parameters before outputting them back in an admin dashboard, leading to Reflected Cross-Site Scripting
Affected products
- Anti-Malware Security and Brute-Force Firewall: before 4.21.83 — fixed in 4.21.83
How to fix
Upgrade to a fixed version: Anti-Malware Security and Brute-Force Firewall 4.21.83. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/276a7fc5-3d0d-446d-92cf-20060aecd0ef
- https://wpscan.com/vulnerability/276a7fc5-3d0d-446d-92cf-20060aecd0ef
Get alerted when CVE-2022-2599 or the next vulnerability affects your stack