What’s Vulnerable › Vulnerabilities
CVE-2022-26134: Atlassian Confluence Server and Data Center Remote Code Execution Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-06-02
- EPSS: 100.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-03 · updated 2026-06-17
- Weakness: CWE-917
Description
In affected versions of Confluence Server and Data Center, an OGNL injection vulnerability exists that would allow an unauthenticated attacker to execute arbitrary code on a Confluence Server or Data Center instance. The affected versions are from 1.3.0 before 7.4.17, from 7.13.0 before 7.13.7, from 7.14.0 before 7.14.3, from 7.15.0 before 7.15.2, from 7.16.0 before 7.16.4, from 7.17.0 before 7.17.4, and from 7.18.0 before 7.18.1.
Affected products
- Atlassian Confluence Data Center: from 1.3 before 7.4.17; from 7.13.0 before 7.13.7; from 7.14.0 before 7.14.3; from 7.15.0 before 7.15.2; from 7.16.0 before 7.16.4; from 7.17.0 before 7.17.4 — fixed in 7.13.7, 7.14.3, 7.15.2, 7.16.4, 7.17.4, 7.4.17
- Atlassian Confluence Data Center: from 1.3 before 7.4.17; from 7.13.0 before 7.13.7; from 7.14.0 before 7.14.3; from 7.15.0 before 7.15.2; from 7.16.0 before 7.16.4; from 7.17.0 before 7.17.4 — fixed in 7.13.7, 7.14.3, 7.15.2, 7.16.4, 7.17.4, 7.4.17
How to fix
Upgrade to a fixed version: Atlassian Confluence Data Center 7.13.7, 7.14.3, 7.15.2, 7.16.4; Atlassian Confluence Data Center 7.13.7, 7.14.3, 7.15.2, 7.16.4. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/167430/Confluence-OGNL-Injection-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/167431/Through-The-Wire-CVE-2022-26134-Confluence-Proof-Of-Concept.html
- http://packetstormsecurity.com/files/167432/Confluence-OGNL-Injection-Proof-Of-Concept.html
- http://packetstormsecurity.com/files/167449/Atlassian-Confluence-Namespace-OGNL-Injection.html
- https://confluence.atlassian.com/doc/confluence-security-advisory-2022-06-02-1130377146.html
- https://jira.atlassian.com/browse/CONFSERVER-79016
- http://packetstormsecurity.com/files/167430/Confluence-OGNL-Injection-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/167431/Through-The-Wire-CVE-2022-26134-Confluence-Proof-Of-Concept.html
- http://packetstormsecurity.com/files/167432/Confluence-OGNL-Injection-Proof-Of-Concept.html
- http://packetstormsecurity.com/files/167449/Atlassian-Confluence-Namespace-OGNL-Injection.html
- https://confluence.atlassian.com/doc/confluence-security-advisory-2022-06-02-1130377146.html
- https://jira.atlassian.com/browse/CONFSERVER-79016
Get alerted when CVE-2022-26134 or the next vulnerability affects your stack