What’s Vulnerable › Vulnerabilities

CVE-2022-26136

Description

A vulnerability in multiple Atlassian products allows a remote, unauthenticated attacker to bypass Servlet Filters used by first and third party apps. The impact depends on which filters are used by each app, and how the filters are used. This vulnerability can result in authentication bypass and cross-site scripting. Atlassian has released updates that fix the root cause of this vulnerability, but has not exhaustively enumerated all potential consequences of this vulnerability. Atlassian Bamboo versions are affected before 8.0.9, from 8.1.0 before 8.1.8, and from 8.2.0 before 8.2.4. Atlassian Bitbucket versions are affected before 7.6.16, from 7.7.0 before 7.17.8, from 7.18.0 before 7.19.5, from 7.20.0 before 7.20.2, from 7.21.0 before 7.21.2, and versions 8.0.0 and 8.1.0. Atlassian Confluence versions are affected before 7.4.17, from 7.5.0 before 7.13.7, from 7.14.0 before 7.14.3, from 7.15.0 before 7.15.2, from 7.16.0 before 7.16.4, from 7.17.0 before 7.17.4, and version 7.21.0. Atlassian Crowd versions are affected before 4.3.8, from 4.4.0 before 4.4.2, and version 5.0.0. Atlassian Fisheye and Crucible versions before 4.8.10 are affected. Atlassian Jira versions are affected before 8.13.22, from 8.14.0 before 8.20.10, and from 8.21.0 before 8.22.4. Atlassian Jira Service Management versions are affected before 4.13.22, from 4.14.0 before 4.20.10, and from 4.21.0 before 4.22.4.

Affected products

How to fix

Upgrade to a fixed version: Atlassian Bamboo 7.2.10, 8.0.9, 8.1.8, 8.2.4; Atlassian Bitbucket Server 7.17.8, 7.19.5, 7.20.2, 7.21.2; Atlassian Confluence Data Center 7.13.7, 7.14.3, 7.15.2, 7.16.4; Atlassian Confluence Data Center 7.13.7, 7.14.3, 7.15.2, 7.16.4; Atlassian Crowd 4.3.8, 4.4.2; Atlassian Crucible 4.8.10; Atlassian Fisheye 4.8.10; Atlassian Jira 8.13.22, 8.20.10, 8.22.4; Atlassian Jira 8.13.22, 8.20.10, 8.22.4; Atlassian Jira Service Desk Server 4.13.22; Atlassian Jira Service Management 4.20.10, 4.22.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-26136 or the next vulnerability affects your stack