What’s Vulnerable › Vulnerabilities
CVE-2022-2625
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-18 · updated 2026-06-17
- Weakness: CWE-915
Description
A vulnerability was found in PostgreSQL. This attack requires permission to create non-temporary objects in at least one schema, the ability to lure or wait for an administrator to create or update an affected extension in that schema, and the ability to lure or wait for a victim to use the object targeted in CREATE OR REPLACE or CREATE IF NOT EXISTS. Given all three prerequisites, this flaw allows an attacker to run arbitrary code as the victim role, which may be a superuser.
Affected products
- Fedoraproject Fedora: 36
- PostgreSQL: from 10.0 before 10.22; from 11.0 before 11.17; from 12.0 before 12.12; from 13.0 before 13.8; from 14.0 before 14.5; 15-beta1, 15-beta2 — fixed in 10.22, 11.17, 12.12, 13.8, 14.5
- Red Hat Enterprise Linux: 6.0, 7.0, 8.0, 9.0
How to fix
Upgrade to a fixed version: PostgreSQL 10.22, 11.17, 12.12, 13.8. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2113825
- https://security.gentoo.org/glsa/202211-04
- https://www.postgresql.org/about/news/postgresql-145-138-1212-1117-1022-and-15-beta-3-released-2496/
- https://bugzilla.redhat.com/show_bug.cgi?id=2113825
- https://security.gentoo.org/glsa/202211-04
- https://www.postgresql.org/about/news/postgresql-145-138-1212-1117-1022-and-15-beta-3-released-2496/
Get alerted when CVE-2022-2625 or the next vulnerability affects your stack