What’s Vulnerable › Vulnerabilities
CVE-2022-2628: DSGVO All in one for WP < 4.2 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-03 · updated 2026-06-17
- Weakness: CWE-79
Description
The DSGVO All in one for WP WordPress plugin before 4.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Michael Leithold DSGVO All in one for WP: before 4.2 — fixed in 4.2
How to fix
Upgrade to a fixed version: Michael Leithold DSGVO All in one for WP 4.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e712f83e-b437-4bc6-9511-2b0290ed315d
- https://wpscan.com/vulnerability/e712f83e-b437-4bc6-9511-2b0290ed315d
Get alerted when CVE-2022-2628 or the next vulnerability affects your stack