What’s Vulnerable › Vulnerabilities
CVE-2022-26305: Execution of Untrusted Macros Due to Improper Certificate Validation
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-25 · updated 2026-06-17
- Weakness: CWE-295
Description
An Improper Certificate Validation vulnerability in LibreOffice existed where determining if a macro was signed by a trusted author was done by only matching the serial number and issuer string of the used certificate with that of a trusted certificate. This is not sufficient to verify that the macro was actually signed with the certificate. An adversary could therefore create an arbitrary certificate with a serial number and an issuer string identical to a trusted certificate which LibreOffice would present as belonging to the trusted author, potentially leading to the user to execute arbitrary code contained in macros improperly trusted. This issue affects: The Document Foundation LibreOffice 7.2 versions prior to 7.2.7; 7.3 versions prior to 7.3.1.
Affected products
- The Document Foundation LibreOffice: from 7.2.0 before 7.2.7; from 7.3.0 before 7.3.2 — fixed in 7.2.7, 7.3.2
How to fix
Upgrade to a fixed version: The Document Foundation LibreOffice 7.2.7, 7.3.2. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2023/03/msg00022.html
- https://www.libreoffice.org/about-us/security/advisories/cve-2022-26305
- https://lists.debian.org/debian-lts-announce/2023/03/msg00022.html
- https://www.libreoffice.org/about-us/security/advisories/cve-2022-26305
Get alerted when CVE-2022-26305 or the next vulnerability affects your stack