What’s Vulnerable › Vulnerabilities
CVE-2022-26306: Execution of Untrusted Macros Due to Improper Certificate Validation
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-25 · updated 2026-06-17
- Weakness: CWE-326
Description
LibreOffice supports the storage of passwords for web connections in the user’s configuration database. The stored passwords are encrypted with a single master key provided by the user. A flaw in LibreOffice existed where the required initialization vector for encryption was always the same which weakens the security of the encryption making them vulnerable if an attacker has access to the user's configuration data. This issue affects: The Document Foundation LibreOffice 7.2 versions prior to 7.2.7; 7.3 versions prior to 7.3.1.
Affected products
- Debian Linux: 10.0
- The Document Foundation LibreOffice: from 7.2.0 before 7.2.7; from 7.3.0 before 7.3.3 — fixed in 7.2.7, 7.3.3
How to fix
Upgrade to a fixed version: The Document Foundation LibreOffice 7.2.7, 7.3.3. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/08/13/1
- https://lists.debian.org/debian-lts-announce/2023/03/msg00022.html
- https://www.libreoffice.org/about-us/security/advisories/cve-2022-26306
- http://www.openwall.com/lists/oss-security/2022/08/13/1
- https://lists.debian.org/debian-lts-announce/2023/03/msg00022.html
- https://www.libreoffice.org/about-us/security/advisories/cve-2022-26306
Get alerted when CVE-2022-26306 or the next vulnerability affects your stack