What’s Vulnerable › Vulnerabilities
CVE-2022-26318: WatchGuard Firebox and XTM Appliances Arbitrary Code Execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-03-25
- EPSS: 78.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-04 · updated 2026-06-17
Description
On WatchGuard Firebox and XTM appliances, an unauthenticated user can execute arbitrary code, aka FBX-22786. This vulnerability impacts Fireware OS before 12.7.2_U2, 12.x before 12.1.3_U8, and 12.2.x through 12.5.x before 12.5.9_U2.
Affected products
- WatchGuard Fireware OS: from 12.0.0 before 12.1.3; from 12.5 before 12.5.9; from 12.7.0 before 12.7.2; 12.1.3, 12.1.3-u1, 12.1.3-u2, 12.1.3-u3, 12.1.3-u4, 12.1.3-u5 (+4) — fixed in 12.1.3, 12.5.9, 12.7.2
How to fix
Upgrade to a fixed version: WatchGuard Fireware OS 12.1.3, 12.5.9, 12.7.2. Check the vendor advisory for mitigations.
References
- https://www.watchguard.com/support/release-notes/fireware/12/en-US/EN_ReleaseNotes_Fireware_12_7_2/index.html#Fireware/en-US/resolved_issues.html
- https://www.watchguard.com/support/release-notes/fireware/12/en-US/EN_ReleaseNotes_Fireware_12_7_2/index.html#Fireware/en-US/resolved_issues.html
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2022-26318
Get alerted when CVE-2022-26318 or the next vulnerability affects your stack