What’s Vulnerable › Vulnerabilities
CVE-2022-2635: Autoptimize < 3.1.1 - Admin+ Stored Cross Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The Autoptimize WordPress plugin before 3.1.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Autoptimize: before 3.1.1 — fixed in 3.1.1
How to fix
Upgrade to a fixed version: Autoptimize 3.1.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/219767a8-2427-42d5-8734-bd197d9ab46b
- https://wpscan.com/vulnerability/219767a8-2427-42d5-8734-bd197d9ab46b
Get alerted when CVE-2022-2635 or the next vulnerability affects your stack