What’s Vulnerable › Vulnerabilities

CVE-2022-26377: mod_proxy_ajp: Possible request smuggling

Description

Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in mod_proxy_ajp of Apache HTTP Server allows an attacker to smuggle requests to the AJP server it forwards requests to. This issue affects Apache HTTP Server Apache HTTP Server 2.4 version 2.4.53 and prior versions.

Affected products

How to fix

Upgrade to a fixed version: Apache HTTP Server 2.4.54. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-26377 or the next vulnerability affects your stack