What’s Vulnerable › Vulnerabilities
CVE-2022-2639
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-01 · updated 2026-06-17
- Weakness: CWE-192
Description
An integer coercion error was found in the openvswitch kernel module. Given a sufficiently large number of actions, while copying and reserving memory for a new action of a new flow, the reserve_sfa_size() function does not return -EMSGSIZE as expected, potentially leading to an out-of-bounds write access. This flaw allows a local user to crash or potentially escalate their privileges on the system.
Affected products
- Linux kernel: from 3.18.139 before 3.19; from 4.4.179 before 4.5; from 4.9.169 before 4.9.312; from 4.14.112 before 4.14.277; from 4.19.35 before 4.19.240; from 5.0.8 before 5.4.191 — fixed in 3.19, 4.14.277, 4.19.240, 4.5, 4.9.312, 5.10.113
- Red Hat Enterprise Linux: 8.0, 9.0
How to fix
Upgrade to a fixed version: Linux kernel 3.19, 4.14.277, 4.19.240, 4.5. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2084479
- https://github.com/torvalds/linux/commit/cefa91b2332d7009bc0be5d951d6cbbf349f90f8
- https://bugzilla.redhat.com/show_bug.cgi?id=2084479
- https://github.com/torvalds/linux/commit/cefa91b2332d7009bc0be5d951d6cbbf349f90f8
Get alerted when CVE-2022-2639 or the next vulnerability affects your stack