What’s Vulnerable › Vulnerabilities
CVE-2022-26495
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-06 · updated 2026-06-17
- Weakness: CWE-190
Description
In nbd-server in nbd before 3.24, there is an integer overflow with a resultant heap-based buffer overflow. A value of 0xffffffff in the name length field will cause a zero-sized buffer to be allocated for the name, resulting in a write to a dangling pointer. This issue exists for the NBD_OPT_INFO, NBD_OPT_GO, and NBD_OPT_EXPORT_NAME messages.
Affected products
- Debian Linux: 9.0, 10.0, 11.0
- Fedoraproject Fedora: 34, 35, 36
- Network Block Device Project Network Block Device: before 3.24 — fixed in 3.24
How to fix
Upgrade to a fixed version: Network Block Device Project Network Block Device 3.24. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2022/03/msg00014.html
- https://lists.debian.org/nbd/2022/01/msg00037.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/G2UPX62BIWOOHSACGUDB7E3O4URNN37F/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/IZHR73XMAJTCFGKUZRXVTZKCK2X3IFNA/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PU5JFD4PEJED72TZLZ5R2Q2SFXICU5I5/
- https://security.gentoo.org/glsa/202402-10
- https://sourceforge.net/projects/nbd/files/nbd/
- https://www.debian.org/security/2022/dsa-5100
- https://lists.debian.org/debian-lts-announce/2022/03/msg00014.html
- https://lists.debian.org/nbd/2022/01/msg00037.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/G2UPX62BIWOOHSACGUDB7E3O4URNN37F/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/IZHR73XMAJTCFGKUZRXVTZKCK2X3IFNA/
Get alerted when CVE-2022-26495 or the next vulnerability affects your stack