What’s Vulnerable › Vulnerabilities
CVE-2022-2650: Improper Restriction of Excessive Authentication Attempts in wger-project/wger
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-24 · updated 2026-06-17
- Weakness: CWE-307
Description
Improper Restriction of Excessive Authentication Attempts in GitHub repository wger-project/wger prior to 2.2.
Affected products
- wger-project wger: before 2.2 — fixed in 2.2
How to fix
Upgrade to a fixed version: wger-project wger 2.2. Check the vendor advisory for mitigations.
References
- https://github.com/wger-project/wger/commit/5e3167e3a2dc95836fa2607fe201524c031a2c4c
- https://huntr.dev/bounties/f0d85efa-4e78-4b1d-848f-edea115af64b
- https://github.com/wger-project/wger/commit/5e3167e3a2dc95836fa2607fe201524c031a2c4c
- https://huntr.dev/bounties/f0d85efa-4e78-4b1d-848f-edea115af64b
Get alerted when CVE-2022-2650 or the next vulnerability affects your stack