What’s Vulnerable › Vulnerabilities
CVE-2022-2657: Multivendor Marketplace Solution for WooCommerce < 3.8.12 - Unauthorised AJAX Calls
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-05 · updated 2026-06-17
- Weakness: CWE-352
Description
The Multivendor Marketplace Solution for WooCommerce WordPress plugin before 3.8.12 is lacking authorisation and CSRF in multiple AJAX actions, which could allow any authenticated users, such as subscriber to call them and suspend vendors (reporter by the submitter) or update arbitrary order status (identified by WPScan when verifying the issue) for example. Other unauthenticated attacks are also possible, either directly or via CSRF
Affected products
- Multivendor Marketplace Solution for WooCommerce – WC Marketplace: before 3.8.12 — fixed in 3.8.12
How to fix
Upgrade to a fixed version: Multivendor Marketplace Solution for WooCommerce – WC Marketplace 3.8.12. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c600dd04-f6aa-430b-aefb-c4c6d554c41a
- https://wpscan.com/vulnerability/c600dd04-f6aa-430b-aefb-c4c6d554c41a
Get alerted when CVE-2022-2657 or the next vulnerability affects your stack