What’s Vulnerable › Vulnerabilities
CVE-2022-2658: WP Spell Check < 9.13 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-16 · updated 2026-06-17
Description
The WP Spell Check WordPress plugin before 9.13 does not escape ignored words, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- WP Spell Check: before 9.13 — fixed in 9.13
How to fix
Upgrade to a fixed version: WP Spell Check 9.13. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e72fa040-3ca5-4570-9a3c-c704574b1ca3
- https://wpscan.com/vulnerability/e72fa040-3ca5-4570-9a3c-c704574b1ca3
Get alerted when CVE-2022-2658 or the next vulnerability affects your stack