What’s Vulnerable › Vulnerabilities
CVE-2022-26616
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-04 · updated 2026-06-17
- Weakness: CWE-79
Description
PKP Vendor Open Journal System v2.4.8 to v3.3.8 allows attackers to perform reflected cross-site scripting (XSS) attacks via crafted HTTP headers.
Affected products
- Public Knowledge Project Open Journal Systems: from 2.4.8 before 3.3.0-9 — fixed in 3.3.0-9
How to fix
Upgrade to a fixed version: Public Knowledge Project Open Journal Systems 3.3.0-9. Check the vendor advisory for mitigations.
References
- https://forum.pkp.sfu.ca/t/ojs-omp-ops-3-3-0-9-released/72236
- https://github.com/pkp/pkp-lib/issues/7649
- https://forum.pkp.sfu.ca/t/ojs-omp-ops-3-3-0-9-released/72236
- https://github.com/pkp/pkp-lib/issues/7649
Get alerted when CVE-2022-26616 or the next vulnerability affects your stack