What’s Vulnerable › Vulnerabilities
CVE-2022-26651
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-15 · updated 2026-06-17
- Weakness: CWE-89
Description
An issue was discovered in Asterisk through 19.x and Certified Asterisk through 16.8-cert13. The func_odbc module provides possibly inadequate escaping functionality for backslash characters in SQL queries, resulting in user-provided data creating a broken SQL query or possibly a SQL injection. This is fixed in 16.25.2, 18.11.2, and 19.3.2, and 16.8-cert14.
Affected products
- Debian Linux: 10.0, 11.0
- Digium Asterisk: from 16.0.0 before 16.25.2; from 18.0 before 18.11.2; from 19.0.0 before 19.3.2 — fixed in 16.25.2, 18.11.2, 19.3.2
- Digium Certified Asterisk: 16.8, 16.8-cert1-rc1, 16.8-cert1-rc2, 16.8-cert1-rc3, 16.8-cert1-rc4, 16.8-cert10 (+15)
How to fix
Upgrade to a fixed version: Digium Asterisk 16.25.2, 18.11.2, 19.3.2. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/166746/Asterisk-Project-Security-Advisory-AST-2022-003.html
- https://downloads.asterisk.org/pub/security/
- https://downloads.asterisk.org/pub/security/AST-2022-003.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00021.html
- https://www.debian.org/security/2022/dsa-5285
- http://packetstormsecurity.com/files/166746/Asterisk-Project-Security-Advisory-AST-2022-003.html
- https://downloads.asterisk.org/pub/security/
- https://downloads.asterisk.org/pub/security/AST-2022-003.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00021.html
- https://www.debian.org/security/2022/dsa-5285
Get alerted when CVE-2022-26651 or the next vulnerability affects your stack