What’s Vulnerable › Vulnerabilities
CVE-2022-26839: Delta Electronics DIAEnergie Incorrect Default Permissions
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-29 · updated 2026-06-17
- Weakness: CWE-276
Description
Delta Electronics DIAEnergie (All versions prior to 1.8.02.004) is vulnerable to an incorrect default permission in the DIAEnergie application, which may allow an attacker to plant new files (such as DLLs) or replace existing executable files.
Affected products
- Delta Electronics DIAEnergie: before 1.8.02.004 — fixed in 1.8.02.004
How to fix
Upgrade to a fixed version: Delta Electronics DIAEnergie 1.8.02.004. Check the vendor advisory for mitigations.
References
- https://www.cisa.gov/uscert/ics/advisories/icsa-22-081-01
- https://www.cisa.gov/uscert/ics/advisories/icsa-22-081-01
Get alerted when CVE-2022-26839 or the next vulnerability affects your stack