What’s Vulnerable › Vulnerabilities
CVE-2022-26850: Insufficiently protected credentials
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-06 · updated 2026-06-17
- Weakness: CWE-668
Description
When creating or updating credentials for single-user access, Apache NiFi wrote a copy of the Login Identity Providers configuration to the operating system temporary directory. On most platforms, the operating system temporary directory has global read permissions. NiFi immediately moved the temporary file to the final configuration directory, which significantly limited the window of opportunity for access. NiFi 1.16.0 includes updates to replace the Login Identity Providers configuration without writing a file to the operating system temporary directory.
Affected products
- Apache Software Foundation Apache NiFi: from 1.14.0 before 1.16.0 — fixed in 1.16.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache NiFi 1.16.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/04/06/2
- https://nifi.apache.org/security.html#CVE-2022-26850
- http://www.openwall.com/lists/oss-security/2022/04/06/2
- https://nifi.apache.org/security.html#CVE-2022-26850
Get alerted when CVE-2022-26850 or the next vulnerability affects your stack