What’s Vulnerable › Vulnerabilities
CVE-2022-2696: Restaurant Menu – Food Ordering System – Table Reservation <= 2.3.0 - Missing Authorization on AJAX Actions
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-03 · updated 2026-06-17
- Weakness: CWE-862
Description
The Restaurant Menu – Food Ordering System – Table Reservation plugin for WordPress is vulnerable to authorization bypass via several AJAX actions in versions up to, and including 2.3.0 due to missing capability checks and missing nonce validation. This makes it possible for authenticated attackers with minimal permissions to perform a wide variety of actions such as modifying the plugin's settings and modifying the ordering system preferences.
Affected products
- gloriafood Restaurant Menu – Food Ordering System – Table Reservation: before 2.3.1 — fixed in 2.3.1
How to fix
Upgrade to a fixed version: gloriafood Restaurant Menu – Food Ordering System – Table Reservation 2.3.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/menu-ordering-reservations/trunk/includes/admin/class-glf-admin-screens.php?rev=2664283
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2793398%40menu-ordering-reservations&new=2793398%40menu-ordering-reservations&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/01486af8-b378-4663-a9c5-167b8580db94?source=cve
- https://www.wordfence.com/vulnerability-advisories-continued/#CVE-2022-2696
- https://plugins.trac.wordpress.org/browser/menu-ordering-reservations/trunk/includes/admin/class-glf-admin-screens.php?rev=2664283
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2793398%40menu-ordering-reservations&new=2793398%40menu-ordering-reservations&sfp_email=&sfph_mail=
- https://www.wordfence.com/vulnerability-advisories-continued/#CVE-2022-2696
Get alerted when CVE-2022-2696 or the next vulnerability affects your stack