What’s Vulnerable › Vulnerabilities
CVE-2022-2710: Scroll To Top < 1.4.1 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-19 · updated 2026-06-17
- Weakness: CWE-79
Description
The Scroll To Top WordPress plugin before 1.4.1 does not escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Scroll To Top: before 1.4.1 — fixed in 1.4.1
How to fix
Upgrade to a fixed version: Scroll To Top 1.4.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/f730f584-2370-49f9-a094-a5bc521671c1
- https://wpscan.com/vulnerability/f730f584-2370-49f9-a094-a5bc521671c1
Get alerted when CVE-2022-2710 or the next vulnerability affects your stack