What’s Vulnerable › Vulnerabilities
CVE-2022-2711: WP All Import < 3.6.9 - Admin+ Directory traversal via file upload
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-07 · updated 2026-06-17
- Weakness: CWE-22
Description
The Import any XML or CSV File to WordPress plugin before 3.6.9 is not validating the paths of files contained in uploaded zip archives, allowing highly privileged users, such as admins, to write arbitrary files to any part of the file system accessible by the web server via a path traversal vector.
Affected products
- Import any XML or CSV File to WordPress: before 3.6.9 — fixed in 3.6.9
How to fix
Upgrade to a fixed version: Import any XML or CSV File to WordPress 3.6.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/11e73c23-ff5f-42e5-a4b0-0971652dcea1
- https://wpscan.com/vulnerability/11e73c23-ff5f-42e5-a4b0-0971652dcea1
Get alerted when CVE-2022-2711 or the next vulnerability affects your stack