What’s Vulnerable › Vulnerabilities
CVE-2022-2713: Insufficient Session Expiration in cockpit-hq/cockpit
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-08 · updated 2026-06-17
- Weakness: CWE-613
Description
Insufficient Session Expiration in GitHub repository cockpit-hq/cockpit prior to 2.2.0.
Affected products
- cockpit-hq/cockpit: before 2.2.0 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: cockpit-hq/cockpit 2.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/cockpit-hq/cockpit/commit/dd8d0314912fa6517ebd2cc9939d9fafbe68731b
- https://huntr.dev/bounties/3080fc96-75d7-4868-84de-9fc8c9b90290
- https://github.com/cockpit-hq/cockpit/commit/dd8d0314912fa6517ebd2cc9939d9fafbe68731b
- https://huntr.dev/bounties/3080fc96-75d7-4868-84de-9fc8c9b90290
Get alerted when CVE-2022-2713 or the next vulnerability affects your stack