What’s Vulnerable › Vulnerabilities
CVE-2022-27157
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-15 · updated 2026-06-17
- Weakness: CWE-640
Description
pearweb < 1.32 is suffers from a Weak Password Recovery Mechanism via include/users/passwordmanage.php.
Affected products
- php Pearweb: before 1.32.0 — fixed in 1.32.0
How to fix
Upgrade to a fixed version: php Pearweb 1.32.0. Check the vendor advisory for mitigations.
References
- https://github.com/pear/pearweb/commit/6447c174a6b4bd76d28ecca8543cbd24bf394f99#diff-204452a70c5b0b0084097fcff6aee77c2c38cb77a41c4b2dd0065fda37a7489c
- https://github.com/pear/pearweb/commit/6447c174a6b4bd76d28ecca8543cbd24bf394f99#diff-204452a70c5b0b0084097fcff6aee77c2c38cb77a41c4b2dd0065fda37a7489c
Get alerted when CVE-2022-27157 or the next vulnerability affects your stack