What’s Vulnerable › Vulnerabilities
CVE-2022-27166: XSS vulnerability on XHRHtml2Markup.jsp in JSPWiki 2.11.2
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 86.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-04 · updated 2026-06-17
- Weakness: CWE-79
Description
A carefully crafted request on XHRHtml2Markup.jsp could trigger an XSS vulnerability on Apache JSPWiki up to and including 2.11.2, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim.
Affected products
- Apache Software Foundation Apache JSPWiki: before 2.11.3 — fixed in 2.11.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache JSPWiki 2.11.3. Check the vendor advisory for mitigations.
References
- https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2022-28732
- https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2022-28732
Get alerted when CVE-2022-27166 or the next vulnerability affects your stack