What’s Vulnerable › Vulnerabilities
CVE-2022-27197
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-15 · updated 2026-06-17
- Weakness: CWE-79
Description
Jenkins Dashboard View Plugin 2.18 and earlier does not perform URL validation for the Iframe Portlet's Iframe source URL, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to configure views.
Affected products
- Jenkins project Jenkins Dashboard View Plugin: before 2.18.1 — fixed in 2.18.1
How to fix
Upgrade to a fixed version: Jenkins project Jenkins Dashboard View Plugin 2.18.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/03/15/2
- https://www.jenkins.io/security/advisory/2022-03-15/#SECURITY-2559
- http://www.openwall.com/lists/oss-security/2022/03/15/2
- https://www.jenkins.io/security/advisory/2022-03-15/#SECURITY-2559
Get alerted when CVE-2022-27197 or the next vulnerability affects your stack