What’s Vulnerable › Vulnerabilities
CVE-2022-27198
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-15 · updated 2026-06-17
- Weakness: CWE-352
Description
A cross-site request forgery (CSRF) vulnerability in Jenkins CloudBees AWS Credentials Plugin 189.v3551d5642995 and earlier allows attackers with Overall/Read permission to connect to an AWS service using an attacker-specified token.
Affected products
- Jenkins project Jenkins CloudBees AWS Credentials Plugin: through 189.v3551d5642995; from 1.28 before 1.28.2; 1.32 — fixed in 1.28.2
How to fix
Upgrade to a fixed version: Jenkins project Jenkins CloudBees AWS Credentials Plugin 1.28.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/03/15/2
- https://www.jenkins.io/security/advisory/2022-03-15/#SECURITY-2351
- http://www.openwall.com/lists/oss-security/2022/03/15/2
- https://www.jenkins.io/security/advisory/2022-03-15/#SECURITY-2351
Get alerted when CVE-2022-27198 or the next vulnerability affects your stack